ESReality - Where Gaming Meets Reality
Not Logged In | Login | Register
13:49 CST - 910 users online
All Posts
Music + FPS Gaming: Sennheiser HD600 vs HD660S (3 comments)
Posted by beAsty @ 13:46 CST, 17 November 2018 - iMsg
Hello everyone,
I currently own a pair of Sennheiser HD600 that I have been using for several years in order to listen to music (classical, jazz, electronic, rock, pop, basically everything if the source quality is decent) and playing fps games on a high level (nationscup, price money events,....).

At the moment I am living in two different countries and travel between my two flats weekly. So I will need another pair of headphones and wondered if I should get the better(?) HD660S. That way I would keep the better HD660S in the flat that I am mostly at and the HD600 in the other flat.

The question is: Are the HD660S any better than the HD600 in terms of sound quality, pin pointing noise ingame, etc... ?

I will most likely drive them with NFB 11 or R2R.
3276 Hits
So quakelive is down ?! (7 comments)
Posted by beAsty @ 10:13 CDT, 12 May 2016 - iMsg
So I haven't been playing Quakelive for ~2years... I just wanted to check my account and noticed that quakelive.com redirects me to steam.

What is that?
Is my account gone?
Are the "clans" still there in which I was?
Do I still have my friends list?
Can I even expect any of my old buddies to be active?

Shoutout to T1E, mumu, xanthic, ROFL, dronsu, swords, kazunoko, T1hol, Uraz, pinaZZ, seiya, Ba77osaI, h8m3, ulbe, He4rTL3sS, ..... and all the others that I am forgetting right now :(
3175 Hits
Weird FPS problem on new laptop-Optimus? (67 comments)
Posted by beAsty @ 13:28 CST, 2 January 2014 - iMsg
So I got my new laptop today:

Dell XPS 15 - 9530
Display: 15.6" QHD (3200x1800) Touchscreen
CPU: Intel i7-4702HQ 2.2-3.2Ghz
RAM: 16GB
Graphics: NVIDIA GT 750M + Intel HD 4600
Optical: None
SSD: Samsung SSD SM841 mSATA 512GB

and when I first tried QL I easily got constant 250fps on overkill & campgrounds. I then installed some apps, removed some junk software and played around a little with that laptop until I finally decided to connect my external screen via HDMI (no displayport cable at home :( no 144Hz for me right now). Turns out -> I can't even get 125fps constant anymore.

I fully disabled the Intel HD 4600 graphics and "r_lastvalidrenderer" shows the GT 750M. But for some reason I lag like hell. From time to time I managed to get constant 250 fps in window mode (same resolution as full screen mode). But also that is gone now.

My previous laptop could handle 250 fps easily as well:

MALIBAL Satori P170HM
Display: 17.3" FullHD 120Hz 3D Matte
CPU: Intel i7-2760QM 2.4-3.5Ghz
RAM: 8GB - upgraded myself to 16GB
Graphics: NVIDIA GTX 560 1.5GB
Optical: Blu-ray reader
SSD: Intel 510 SSD 120GB
HDD: Samsung SpinPoint MP4 7200 rpm 640GB
Cooling: IC Diamond CPU + GPU

I am sure my new laptop should also be able to do so. Any ideas what could cause the problems? I believe its some NVIDIA Optimus crap but I already set "USE NVIDIA GPU" in Nvidia control panel settings.

:/
13222 Hits
Next Page >>
Conceived and created by Sujoy Roy (Legal Notices)
RSS Feed Information, Link Buttons and Banners, Report a Bug